Start a new topic

Index was outside the bounds of the array

Experiencing this error today and never seen it before


1 person has this problem

Hi Tristan,


This looks related to the keyboard hot keys features. Are you pressing a specific key combination that is causing the error to appear?

Hi Jason and thanks for the reply.


The error seems to come up even when nothing is playing not long after Playit live is loaded or can be when playing up to an hour or so with no keyboard inputs. The error forces a shutdown of Playit live.


Running on a new Acer desktop, keyboard and mouse through an external usb soundcard. Never had any errors persistent like this so guessing a hardware issue.


I have previously tried disconnecting usb soundcard and using the onboard one, disabling monitored folders, uninstalling latest version to a older version.


I will check keyboard settings and/or try another keyboard next.


Thanks Jason

I'm thinking this might be related to the latest version of AnyDesk - I'm also seeing issues with SAM Broadcaster "Lock Talk" button deselecting after a short time with AnyDesk open. It's happening on three different systems I manage, all when AnyDesk is opened.

We have the same error in Brisbane, we are using anydesk, is this the cause?
Probably, if you are remotely controlling the computer. I have three affected computers if I remote into them but my local copy is fine.
Ok , so turn off any desk? And return to under 5 minute chunks of teamviewer? Its a remote site so this is problematic for me.. but if it solves it I will give it a go. Its causing playit to shut down everytime I go in

This issue is now resolved in the latest version of PlayIt Live: https://www.playitsoftware.com/Products/Live

Well its 3 am In Brisbane , lets out it to the test....
So far Success, thanks Jason...

Thanks for everyone's help and comments.


Yes I found it was being caused by the new version of Anydesk. I am now using Teamviewer as always have a backup for remote access but handy to know Anydesk is now working again with Playit Live.


Best Regards

Login to post a comment