The PlayIt Software Users Facebook group provides a much faster response to questions. Please consider joining.
Start a new topic

Now Playing Plug In not saving txt file


So I purchased the Now Playing plug in and set it up and I thought it had saved the text file. When I opened Rocket Broadcaster to open the file in the same location as I thought I had saved it, it wasn't there. 

I've tried many ways to do this but nothing is working. Hellpppppp.



Well Lee,

I have had this working exactly as you are trying to do.

PlayIt Live settings:


Rocket Broadcaster settings:


The main difference between your settings and mine are where you are putting the file.

I currently use a mapped network drive location (because I run PlayIt Live on two machines and want Rocket to capture Metadata from whichever PlayIt Live system I have running).

Previously I used a location in "Documents" and I think this is where your problem lies. You seem to be saving in C:ProgramData. 

Try "Documents" in the logged in user and I think all will be well.

One other comment (not related to Lee's question but possibly helpful to someone).

I also have a Barix Instreamer (hardware streaming encoder) running.

To send Metadata to this device (at static IP address on my local network) I use the following "NowPlaying" plugin config.


It was a bit tricky to get going so hopefully this is of use to someone. 

Note that this requires using the inbuilt streaming facility (rather than IceCast/Shoutcast) for the metadata to work.

I've not yet got PlayIt Live to push metadata to my Raspberry Pi Icecast server (it's on my list !). 

There are a number of things I would change about the Barix but actually as an ultra-reliable hardware streaming source it is excellent. I've never had it crash or need a reboot.

I've tried in in various locations, Rocket and Playit are both on the same PC so at first I placed in on the desktop, then I placed it on an external drive connected to the PC D:/nowplaying.txt

When i type in the location for rocket to look for the file I can't because no file exists.

Very odd Lee.

If you set PlayIt Live to put the file in what on my pc (user account is called Admin) is


do you get a file called nowplaying.txt created?

Before I moved to using the network drive location that's exactly what I had.

One other thing to try.

The PlayIt Live built in streamer doesn't seem to use the NowPlaying plugin. If you stream from that do you get any metadata.

I assume all your files have correct metadata. 

I don't know which tag (ID1 or ID2) PlayIt Live takes data from so I suggest you check both are present.

Other than those suggestions I'm very puzzled. I can assure you it can work!


In Playit and I save the nowplaying.txt file and then point Rocket to that file, the txt file doesn't exist at all. There is no file, I can't even look for it in File explorer. It seems as Playit isn't writing a file at all.

That's what I suspected.

Why is the question.

Test No 1. Open Notepad (in Windows accessories) and make a file that says 

MyTestArtist - My TestTitle

on one line and save it in the location PlayIt Live is set to save in.

Rocket should see it and update.

Assuming that works we need to find out why PlayIt Live isn't creating the file.

As a starter uncheck the "ignore specific track groups" box and see if that helps.

Also try the built in streamer and see what metadata that produces.

Also have a look at your tracks in a metadata editor (I use Kid3 - Kid3 Tag Editor download | but use it with great care!)

Ok, so I created the nowplaying.txt file and wrote 'MyTestArtist - My TestTitle' and pointed rocket to it. Rocket picked it up and placed it in the Artist and Title boxes.

I checked Metadata for the hour to make sure each track had the right data, which it did. But Rocket wouldn't pick it up at all, it kept showing the MyTestArtist in the boxes.

I looked into the Playit Live streaming plug in and it does show up the text.

?????? Hmmm????????

Hello Lee, I’ll experiment a little further later today. Jus to confirm, your files are MP3 and have both ID3v1& ID3v2 tags (this is what I should have called the tags in the earlier reply).
Yes they are all ID3 and ID4 tags.

I made up a test file with tags identified correctly and (at least with both present) PlayIt Live takes the ID3v2 tag.


I can't think why, but my best guess is that PlayIt Live can't write to the place you are asking it to put "nowplaying.txt".

Rocket Broadcaster is picking up the file OK but PlayIt Live isn't able to write it.

Are there multiple users on the PC ? Is the account in use a Microsoft account but PlayIt Live installed for a different account ? 

I would also make the account you are using an administrator (for an experiment at least). 

I use a Local Account which is an administrator.



I have now managed to break the "Now Playing" plugin.


What I did was to log in on a different user account and ask it to save the file in that account's "Documents" folder.

It does error sensibly with a permissions problem but my guess is that your problem is in some way similar.



Only one user logged in to the pc under one account which is set as admin. 

I don't get the fail to write error either.

I’m running out of ideas I’m afraid. You could delete and reinstall the plugin (you can redownload it without needing to pay again) just in case it didn’t install properly. I also assume you are using current versions of both the main software and plugin.
Login to post a comment