The PlayIt Software Users Facebook group provides a much faster response to questions. Please consider joining.
Start a new topic

Advanced Scheduling

Hi, I've signed up to the trial of the advanced Scheduling module and wondered if anybody had used this before? I'm struggling to find any 'how to guides' or videos about this. I'm wanting to tighten up the hour clocks as I noticed that songs were being cut off at the exact time marker after only playing for a small amount of time. Is there a way of this not happening with the advanced Scheduling module as I'm struggling with the best settings. Any help would be great. Thank you.

Hi Lee,

PlayIt Live will try its best to schedule a selection of tracks that fit the required time given the parameters you have provided. This is dependent on many factors, including the tracks available for selection due to playout policies, the track group it is choosing from, which tracks were played longer ago, and the performance of the machine doing the scheduling. One of the parameters is "seconds per fit" which is the amount of time the scheduler will spend trying to find a suitable set of tracks. If this is set low and scheduling is taking a long time to find one set of tracks then it won't come up with many options.

You should ensure your playout policies and track groups are not so limited as to give PlayIt Live a good selection of tracks to choose from and therefore be able to find a set of tracks that fits to the required time.

So now i've got a 4 minute track starting at 58:58 which means it will be only playing 1 minute of the track, How do I stop this happening? I don't mind it missing maybe a minute off the song but only playing a minute sounds sloppy.

Any help would be great.

Hi Lee,

Leaving the settings unchanged is the same as if you did not have the Advanced Scheduling module. If you wish to have tracks closer to the end of the hour, decrease the Target threshold to 1 second, increase the number of attempts to 50 and include the seconds per fit to 5 seconds. You should add a hard fixed time marker to the start of each hour.

The scheduler should not be under scheduling if the Log Scheduler is ON. The only reason there would be any silence at the end of the hour was if not enough tracks were scheduled and the log scheduler was OFF.

I think I've left the settings as default. Do you see the selection it makes in the playoutog? Does itt select tracks from your entire library? I noticed this morning that a song ended and there was around 30 seconds of silence before the hard time marker was hit.

Hi Lee,

There are currently no videos or how-to guides short of the documentation found here: - the Fitting To Time section.

When the scheduler selects tracks for the hour, it will generate a certain number of options and select the best one that fits within the threshold required. If you are finding that tracks are still being cut off, it may be that there is a limited number of tracks to choose from.

Just to check, please could you show a screenshot of the Fitting to Time settings that you have entered into the Settings > Advanced Scheduling section.

Login to post a comment