Start a new topic

Live Assist mode does not play tracks

Live Assist mode does not play any tracks after a recent Windows 10 update plus a new driver to the Tascam sound card that I'm using. Playing tracks in Desk Mode works fine. Has anyone experienced something similar? Has anyone taken the new build 2165 as this may resolve the issue?


Hello Chris, I've a laptop running the current build of PlayIt Live and an ESI sound card which is up to date on the Windows 10 updates and is working OK.


Does dragging tracks into the schedule work ?


Does your library live on a network drive ?


My library (copy) is on the local drive.


BTW what is the Tascam sound card and what do you think of it ?


I've found the newer Windows 10 builds have upset sound card drivers but I don't think this is your problem.


Hi Mark


Thanks for your response


So I can drag tracks into the schedule but nothing plays. I managed to get it to work in Desk Mode yesterday but now today I'm getting echo /feeback which gets progressively louder in Desk Mode. I also get the same echo/feedback on the mics in the studio. My library is on external drives but loading music from there has worked fine. I think the problem is since the Windows 10 update on the 23rd May. The sound card has also introduced a new driver. The Tascam sound card is an external sound card and has been working fine. It's a Tascam 2x2 is all I can tell you but have a look on line at the spec. I sue something called MBRecaster which is a free utility and that is the s/w between the radio desk, PC and streaming service. There is a new version of that available as well so I might try upgrading to that. Other than that I'm at a loss.

Hello Chris, Start by using the PC built in sound card and listen to that. Select that for the PlayIt Live audio output in all players. Once that works, use the Tascam output. I assume you use that into the mixer. Then feed another source on the mixer back into the PC to your streaming software. The sound card may have a monitor setting which feeds out to in within the soundcard. If so deselect this. I think this process will sort you out.
Login to post a comment